Final Fantasy XIV

Moderator: lil helpers

User avatar
Terminal
Major
Major
Posts: 3252
Joined: Tue Apr 25, 2006 11:00 pm -0500

Final Fantasy XIV

Post by Terminal » Sat Jul 13, 2013 1:26 pm -0500

Get it, try it out, it's in beta now before the release in late august.

They don't try to reinvent the wheel or anything with this one, they've acknowledged that. They have instead taken some of the best aspects from a lot of MMO's (WoW, Rift, SWTOR, etc.) and combined them into one.

I tried SWTOR, I tried playing RIFT, and I played WoW hardcore for years. This is the first MMO that I've really gotten into since WoW. It looks very promising, and is much more complex an interesting than WoW ever was!

User avatar
Xarpolis
General of the Board
General of the Board
Posts: 14824
Joined: Tue Oct 15, 2002 9:51 am -0500
Location: Honolulu, HI
Contact:

Re: Final Fantasy XIV

Post by Xarpolis » Sat Jul 13, 2013 5:23 pm -0500

Ok, I'll give it a shot.

SQUARE ENIX wrote:* You have received this e-mail because of your application for the FINAL FANTASY XIV: A Realm Reborn Beta Test. If you believe you have received this e-mail in error, please delete it.
==========
Thank you for applying to become a FINAL FANTASY XIV: A Realm Reborn Beta Tester.

Selection will be based on the answers submitted in the application, and only successful applicants will be notified. Acceptance notifications will be sent to the e-mail address submitted in the application.

* Selections will be made in each test phase, and the number of testers will be gradually increased.

-----
SQUARE ENIX CO., LTD.
FINAL FANTASY XIV: A Realm Reborn Beta Test Operations Team
No sig for me.

User avatar
Xarpolis
General of the Board
General of the Board
Posts: 14824
Joined: Tue Oct 15, 2002 9:51 am -0500
Location: Honolulu, HI
Contact:

Re: Final Fantasy XIV

Post by Xarpolis » Sat Jul 13, 2013 5:32 pm -0500

I'm trying to run the benchmark thing just because. I have DX11 on this computer, yet it says I can't do it because I don't have DX9. Fun times.
No sig for me.

User avatar
Xarpolis
General of the Board
General of the Board
Posts: 14824
Joined: Tue Oct 15, 2002 9:51 am -0500
Location: Honolulu, HI
Contact:

Re: Final Fantasy XIV

Post by Xarpolis » Sat Jul 13, 2013 5:50 pm -0500

Ok, got the Benchmark thing working. Not a bad score.
Attachments
Benchmark.png
Benchmark.png (484.11 KiB) Viewed 45563 times
No sig for me.

User avatar
Venkmen
Lt. Colonel
Lt. Colonel
Posts: 4972
Joined: Sat Oct 12, 2002 10:03 am -0500
Location: NWA Bitches!!!!

Re: Final Fantasy XIV

Post by Venkmen » Sun Jul 14, 2013 11:45 am -0500

Signed up for Beta. Hope to get an invite. Would love to check it out and see if it is worth a shit. I may buy if it is.

User avatar
Venkmen
Lt. Colonel
Lt. Colonel
Posts: 4972
Joined: Sat Oct 12, 2002 10:03 am -0500
Location: NWA Bitches!!!!

Re: Final Fantasy XIV

Post by Venkmen » Sun Jul 14, 2013 12:04 pm -0500

Boom! E-peen!!!!!
Attachments
Untitled.jpg
Untitled.jpg (333.53 KiB) Viewed 45555 times

User avatar
Xarpolis
General of the Board
General of the Board
Posts: 14824
Joined: Tue Oct 15, 2002 9:51 am -0500
Location: Honolulu, HI
Contact:

Re: Final Fantasy XIV

Post by Xarpolis » Sun Jul 14, 2013 12:24 pm -0500

Let me try that again at your resolution.
No sig for me.

User avatar
Xarpolis
General of the Board
General of the Board
Posts: 14824
Joined: Tue Oct 15, 2002 9:51 am -0500
Location: Honolulu, HI
Contact:

Re: Final Fantasy XIV

Post by Xarpolis » Sun Jul 14, 2013 12:30 pm -0500

Damn, you still beat me.

5815 for my 1920x1080 attempt.

What hardware are you running?
No sig for me.

User avatar
Venkmen
Lt. Colonel
Lt. Colonel
Posts: 4972
Joined: Sat Oct 12, 2002 10:03 am -0500
Location: NWA Bitches!!!!

Re: Final Fantasy XIV

Post by Venkmen » Sun Jul 14, 2013 6:28 pm -0500

core i5 3570k
8 Gig Mushkin Ram
nVidia Geforce GTX660
Mushkin SSD
Gigabyte Z77 Motherboard

User avatar
Xarpolis
General of the Board
General of the Board
Posts: 14824
Joined: Tue Oct 15, 2002 9:51 am -0500
Location: Honolulu, HI
Contact:

Re: Final Fantasy XIV

Post by Xarpolis » Mon Jul 15, 2013 5:22 am -0500

Hmm. I don't get it. Maybe I don't have something configured correctly.

i7 3770k
32 Gig Corsair Vengeance
MSI GTX660
Samsung 840 SSD
Asus Z77 Sabertooth Mobo


I'll have to figure out what's bogging the system down.
No sig for me.

User avatar
Terminal
Major
Major
Posts: 3252
Joined: Tue Apr 25, 2006 11:00 pm -0500

Re: Final Fantasy XIV

Post by Terminal » Mon Jul 15, 2013 1:09 pm -0500

He could have a 660TI or might have an EVGA card or something rather than MSI which might have a slightly higher core-clock. That would cause the small 200 point difference.

User avatar
Venkmen
Lt. Colonel
Lt. Colonel
Posts: 4972
Joined: Sat Oct 12, 2002 10:03 am -0500
Location: NWA Bitches!!!!

Re: Final Fantasy XIV

Post by Venkmen » Tue Jul 16, 2013 5:38 pm -0500

EVGA GTX 660 (Non Ti, Non Superclocked)
No overclock.

I did do an SSD specific install of Win 7. I turns off a lot of the crap that is not needed in the OS due to the speed of the SSD. That could be some of it.

User avatar
Xarpolis
General of the Board
General of the Board
Posts: 14824
Joined: Tue Oct 15, 2002 9:51 am -0500
Location: Honolulu, HI
Contact:

Re: Final Fantasy XIV

Post by Xarpolis » Tue Jul 16, 2013 9:29 pm -0500

How do you set that up?
No sig for me.

User avatar
Terminal
Major
Major
Posts: 3252
Joined: Tue Apr 25, 2006 11:00 pm -0500

Re: Final Fantasy XIV

Post by Terminal » Tue Jul 16, 2013 9:49 pm -0500

btw EVGA GTX660 has a slightly higher core clock and boost clock than the MSI. Just sayin'

User avatar
Xarpolis
General of the Board
General of the Board
Posts: 14824
Joined: Tue Oct 15, 2002 9:51 am -0500
Location: Honolulu, HI
Contact:

Re: Final Fantasy XIV

Post by Xarpolis » Wed Jul 17, 2013 12:51 pm -0500

This is awesome.

No sig for me.

User avatar
Venkmen
Lt. Colonel
Lt. Colonel
Posts: 4972
Joined: Sat Oct 12, 2002 10:03 am -0500
Location: NWA Bitches!!!!

Re: Final Fantasy XIV

Post by Venkmen » Wed Jul 17, 2013 6:14 pm -0500

http://www.overclock.net/t/1156654/sean ... -ssds-hdds

Rn through that. More than anything I have found that it turns off some shit that can extend the life of your SSD. There are some things that can improve performance in there though.

User avatar
Xarpolis
General of the Board
General of the Board
Posts: 14824
Joined: Tue Oct 15, 2002 9:51 am -0500
Location: Honolulu, HI
Contact:

Re: Final Fantasy XIV

Post by Xarpolis » Thu Jul 18, 2013 5:28 pm -0500

My setup looks like this:

Image
No sig for me.

User avatar
Terminal
Major
Major
Posts: 3252
Joined: Tue Apr 25, 2006 11:00 pm -0500

Re: Final Fantasy XIV

Post by Terminal » Thu Jul 18, 2013 9:56 pm -0500

Are you liquid-cooling your processor?

User avatar
Xarpolis
General of the Board
General of the Board
Posts: 14824
Joined: Tue Oct 15, 2002 9:51 am -0500
Location: Honolulu, HI
Contact:

Re: Final Fantasy XIV

Post by Xarpolis » Fri Jul 19, 2013 7:09 am -0500

Yeah. Corsair H110. I tried OCing it to 4.5 ghz in the bios, but I'm not entirely sure that I did it right. I've never tried OCing anything before, so I have no idea if it was successful or not.
No sig for me.

User avatar
Terminal
Major
Major
Posts: 3252
Joined: Tue Apr 25, 2006 11:00 pm -0500

Re: Final Fantasy XIV

Post by Terminal » Fri Jul 19, 2013 1:11 pm -0500

It certainly isn't needed.

I'll take a picture of my heatsink when I get home. The thing is god damn massive. It also keeps my processor at like 28F and I can't hear it so I'm pretty impressed by it.

User avatar
Xarpolis
General of the Board
General of the Board
Posts: 14824
Joined: Tue Oct 15, 2002 9:51 am -0500
Location: Honolulu, HI
Contact:

Re: Final Fantasy XIV

Post by Xarpolis » Fri Jul 19, 2013 1:38 pm -0500

I may not need it, but I have it. My system is whisper quiet.
No sig for me.

User avatar
Terminal
Major
Major
Posts: 3252
Joined: Tue Apr 25, 2006 11:00 pm -0500

Re: Final Fantasy XIV

Post by Terminal » Fri Jul 19, 2013 3:16 pm -0500

i meant you don't need the overclock, not that you don't need the liquid cooling. you won't see any performance boost at all from it

User avatar
Venkmen
Lt. Colonel
Lt. Colonel
Posts: 4972
Joined: Sat Oct 12, 2002 10:03 am -0500
Location: NWA Bitches!!!!

Re: Final Fantasy XIV

Post by Venkmen » Fri Jul 19, 2013 9:01 pm -0500

I went with the Cooler Master Hyper 212 Evo. Best bang for the buck out there. Half or more less than the big boy air coolers for only a degree or two of difference.

User avatar
Terminal
Major
Major
Posts: 3252
Joined: Tue Apr 25, 2006 11:00 pm -0500

Re: Final Fantasy XIV

Post by Terminal » Fri Jul 19, 2013 10:45 pm -0500

ignore the dust and horrible cabling

http://imgur.com/a/lUGBO

this thing was so fucking huge i didn't think it would fit in my case.

Mugaaz
First Lieutenant
First Lieutenant
Posts: 1541
Joined: Tue Oct 15, 2002 11:00 pm -0500

Re: Final Fantasy XIV

Post by Mugaaz » Sun Jul 28, 2013 6:06 pm -0500

Brother and I will be playing this, you guys pick a server? I want to play on a non legacy server.

User avatar
Terminal
Major
Major
Posts: 3252
Joined: Tue Apr 25, 2006 11:00 pm -0500

Re: Final Fantasy XIV

Post by Terminal » Mon Jul 29, 2013 9:04 am -0500

Ultros

Potsnu
Probably not a spambot
Posts: 7
Joined: Tue Aug 06, 2013 12:27 pm -0500

Re: Final Fantasy XIV

Post by Potsnu » Tue Aug 06, 2013 5:16 pm -0500

I'm thinking of playing this very casually. So Ultros is the server?

Probably 2 hours a day max. I haven't played any type of game in 6 months.

User avatar
Terminal
Major
Major
Posts: 3252
Joined: Tue Apr 25, 2006 11:00 pm -0500

Re: Final Fantasy XIV

Post by Terminal » Tue Aug 06, 2013 5:36 pm -0500

Terminal wrote:Ultros

User avatar
Spyle
Probably not a spambot
Posts: 41
Joined: Mon Jul 29, 2013 6:02 pm -0500

Re: Final Fantasy XIV

Post by Spyle » Thu Aug 08, 2013 3:08 pm -0500

Xarpolis wrote:Damn, you still beat me.

5815 for my 1920x1080 attempt.

What hardware are you running?
Just for fun... :ugeek:

Image

Setup:
AMD 7970
Samsung 830 SSD
ImageImageImage
EQ1 on Drinal:
Image
Image
Image
Also: Habitatt (80 nec), Andalee (74 dru), Halo (71 clr), Kolyth (70 mag), Diviah (59 mnk)

WoW (Hyjal-Horde):
Image

User avatar
Xarpolis
General of the Board
General of the Board
Posts: 14824
Joined: Tue Oct 15, 2002 9:51 am -0500
Location: Honolulu, HI
Contact:

Re: Final Fantasy XIV

Post by Xarpolis » Thu Aug 08, 2013 4:19 pm -0500

Jesus christ.
No sig for me.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests